HDU1520-Anniversary party(树形DP 入门)

题目链接

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7

1

1

1

1

1

1

1

1 3

2 3

6 4

7 4

4 5

3 5

0 0

Sample Output

5


题意

有一个树表示上下级关系,父结点是子结点的上级。如果上级来了,下级就不会来。每个人都有一个欢乐值,问来party的所有人的欢乐值之和的最大值是多少?

思路

本来应该要找根节点的,但是这样想,某个人来,他的下级一定是不来的,其实他的上级也是不来的(如果上级来了,他就不来了)。所以一个人来的结果就是他的上级和下级都不回来,上级和下级并没有什么区别,都可以认为是与自己相连的那个人不来。所以根可以随便找,可以把1作为根。

dp[ i ][ j ]表示 i 结点的情况,j 取0或1表示不去或者去,dp[ i ] [ 0 ] 表示 i 节点不去,当前的结点 i 和他的子树所有节点的最大值。

用DFS序走一遍,在后序的位置上判断,那么子树的情况都已经确定了。对于当前节点now,有两种情况:去和不去。

① now去:dp[now][1] += dp[u][0]; 加上子结点不去的情况

②now不去:dp[now][0] += max(dp[u][1],dp[u][0]); 子结点可以去也可以不去,加上最大值

由于一个结点可能有多个子结点,所以要 += .


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxn = 6010;

struct Edge
{
    int to,next;
}edge[maxn*2];

int head[maxn],tot=0;
void addEdge(int from,int to)
{
    edge[tot].to = to; edge[tot].next = head[from];
    head[from] = tot++;
}

int dp[maxn][2],n;

void dfs(int now,int fa)
{
    for(int i=head[now];i!=-1;i=edge[i].next){
        int u = edge[i].to;
        if(u==fa) continue;
        dfs(u,now);
        dp[now][0] += max(dp[u][1],dp[u][0]);
        dp[now][1] += dp[u][0];
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        tot=0;
        memset(head,-1,sizeof(head));
        memset(edge,0,sizeof(edge));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++) scanf("%d",&dp[i][1]);
        int x,y;
        while(~scanf("%d%d",&x,&y)){
            if(x==0&&y==0) break;
            addEdge(x,y);
            addEdge(y,x);
        }
        dfs(1,0);
        printf("%d\n",max(dp[1][0],dp[1][1]));
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值