1538:Gopher II——匈牙利算法二分匹配

描述

The gopher family, having averted the canine threat, must face a new predator.

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

输入

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

输出

Output consists of a single line for each case, giving the number of vulnerable gophers.

样例输入

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

样例输出

1

思路

模板题,复杂度n^3。

代码

#include<bits/stdc++.h>
using namespace std;

int n,m;
double s,v;

struct node{
	double x,y;
}g[1005];
int num[1005];
int vis[1005];
int mp[1005][1005];

bool find(int x){
	for(int i=0;i<m;i++){
		if(!vis[i]&&mp[x][i]){//这个洞没有用过并且x地鼠能到达
			vis[i]=1;//设置为访问过
			if(num[i]==-1||find(num[i])){//洞没被使用,或者使用者可以挪动,该地鼠仍可被满足
				num[i]=x;
				return true;
			}
		}
	}
	return false;
}

int match(){
	int cnt=0;
	for(int i=0;i<n;i++){
		memset(vis,0,sizeof(vis));//初始化每个洞仍可选
		if(find(i)) cnt++;
	}
	return cnt;
}

int main(){
	while(cin>>n>>m>>s>>v){
		memset(num,-1,sizeof(num));
		memset(mp,0,sizeof(mp));
		for(int i=0;i<n;i++){
			cin>>g[i].x >> g[i].y;
		}
		double a,b;
		for(int i=0;i<m;i++){
			cin>>a>>b;
			for(int j=0;j<n;j++){//建图
				if((a-g[j].x)*(a-g[j].x)+(b-g[j].y)*(b-g[j].y)<=v*s*v*s){
					mp[j][i]=1;
				}
			}
		}
		cout << n-match() <<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值