Girls and Boys——最大独立集二分匹配

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output

5 2

 

思路

再次因为输入格式wa哭我,最大独立集=节点个数-最大匹配数。输入格式复杂时用scanf输入。

其他博主的解释是说因为题目没有分男女,而匈牙利算法的初始条件是两个集合不能相交,因此男女混杂相当于两个集合重复了,所以最后结果要除以2。

最大匹配数可以用匈牙利算法求解。注意nxt数组初始化为-1,用的时候要记得它是等于-1的!!!除非节点编号从1开始就可以将它初始化为0,用的时候就用0。记住啊啊啊啊啊!!!!

代码

#include<bits/stdc++.h>
using namespace std;

int mp[1005][1005];
int vis[1005];
int nxt[1005];
int n;

bool find(int x){
	for(int i=0;i<n;i++){
		if(mp[x][i]&&!vis[i]){
			vis[i]=1;
			if(nxt[i]==-1||find(nxt[i])){
				nxt[i]=x;
				return true;
			}
		}
	}
	return false;
}

int match(){
	int sum=0;
	memset(nxt,-1,sizeof(nxt));
	for(int i=0;i<n;i++){
		memset(vis,0,sizeof(vis));
		if(find(i)) sum++;
	}
	return sum; 
}

int main(){
	while(cin>>n){
		memset(mp,0,sizeof(mp));
		for(int i=0;i<n;i++){
			int a,b,k;
			scanf("%d: (%d)",&a,&b);
			for(int j=0;j<b;j++){
				cin>>k;
				mp[a][k]=1;
			}
		}
		cout << n-match()/2 <<endl;
	}
	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值