hdoj 1068 Girls and Boys

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8989    Accepted Submission(s): 4147


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
Sample Output
   
   
5 2
 

大学二年级的时候,一些同学开始研究男女同学之间的缘分。研究者试图找出没有缘分同学的最大集。程序的结果就是要输出这个集合中学生的数量。

3 ----男孩和女孩一共3个

0:
(2) 
1 2 ---- 0号与两个人会恋爱:1,2号

1: (1) 0 ---同上解释

2: (1) 0

分析题目是明显的二分图模型,但是输入没有指明那些是男孩/女孩。所以要拆点,把
i 拆成 i 跟 i' 分别放入X、Y,构造二分图。原先U = V - M,所以 2U = 2V - 2M。
分析:

        故U = n - M'/2。

代码:


#include<stdio.h>
#include<string.h>
#define N 1010
int map[N][N],mode[N],vis[N];
int t;
int find(int x)//寻找增广路! 找到返回1,否则返回0! 
{
	int i,j;
	for(i=0;i<t;i++)
	{
		if(map[x][i]&&!vis[i])//与x相连点,并且没有遍历到 
		{
			vis[i]=1;//标记为遍历过 
			if(!mode[i]||find(mode[i]))//i 点 没有和另一部分匹配或 和i配对的点 没有匹配! 
			{
				mode[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{


	while(scanf("%d",&t)!=EOF)
	{
		int i,j;
		memset(map,0,sizeof(map));
		memset(mode,0,sizeof(mode));
		for(i=0;i<t;i++)
		{
			int tt,x,y;
			scanf("%d: (%d)",&x,&tt);
			while(tt--)
			{
				scanf("%d",&y);
				map[x][y]=1;//标记为通路 
			}
		}
	
			int s=0;
			for(i=0;i<t;i++)
			{
				memset(vis,0,sizeof(vis));
				if(find(i))//增广路 
				{
				s++;
			    }
			}
			printf("%d\n",t-s/2);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值