How Many Answers Are Wrong——带权并查集

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

 

Output

A single line with a integer denotes how many answers are wrong.

 

Sample Input

10 5

1 10 100

7 10 28

1 3 32

4 6 41

6 6 1

 

Sample Output

1

 

思路

记录节点到父节点的距离,该距离表示为节点到根节点的区间累加和。对于每次询问,更新节点的sum函数。

对于节点的移植(find),如果是更新当前节点的根节点,则sum等于原来的sum加上前根节点到新根节点的距离,即sum[x]+=sum[fx];

对于根节点的移植(union),如果两个节点的根节点相同,那么直接通过差值判断是否和输入一样,如果不一样则说明她说谎了。如果两个节点的根节点不同,那么需要更新sum函数,x到y的距离已知,那么fy到x的根节点的距离就等于sum[x]+k-sum[y]。

这里我一直搞不懂为什么不能直接更新sum[fy]+=sum[fx],小小的脑袋大大的疑惑。可能是因为sum[fx]的值不一定更新了吧???

还有一点是,为了减的时候方便,区间和记录成左开右闭。

代码

#include<bits/stdc++.h>
using namespace std;
int n,m,a,b,k,ans;
int f[200005];
int sum[200005];

int find(int x){
	if(x==f[x]) return x;
	int fx=f[x];
	f[x]=find(f[x]);
	sum[x]+=sum[fx];
	return f[x];
}

void myunion(int x,int y,int k){
	int fx=find(x);
	int fy=find(y);
	if(fx==fy){
		if(sum[y]-sum[x]!=k) ans++;
	}else{
		f[fy]=fx;
		sum[fy]=-sum[y]+sum[x]+k;
	}
}

int main(){
	while(cin>>n>>m){
		ans=0;
		for(int i=0;i<=n;i++) f[i]=i,sum[i]=0; //初始化 
		for(int i=0;i<m;i++){
			cin>>a>>b>>k;
			myunion(a-1,b,k);
		}
		cout << ans <<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值