hdu 1175 连连看 搜索

连连看

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44857    Accepted Submission(s): 11211


 

Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

 

 

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

 

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

 

Sample Input

3 4

1 2 3 4

0 0 0 0

4 3 2 1

4

1 1 3 4

1 1 2 4

1 1 3 3

2 1 2 4

3 4

0 1 4 3

0 2 4 1

0 0 0 0

2

1 1 2 4

1 3 2 3

0 0

 

Sample Output

YES

NO

NO

NO

NO

YES

 

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1175

 

memset的头文件 #include<cstring>

记录每一个点的坐标,方向,步数,如果这次的方向和上次的不一样就加1(相当于拐弯),大于2就剪掉,因为每个点又可能来自不同的点即方向不一样,不能使用简单的true和false标记,vis里面应该存步数的值,初始化INF(比2大就行了),每次只允许比vis[x][y]小于等于的点加入队列

细节:codeblocks int bfs()函数没有最后的return 0;不报错= =

 

while(scanf("%d%d",&n,&m),(n+m)){} 这样结束循环不错

#include<iostream>
#include<cstdio>
#include<algorithm>
#include <sstream>
#include <cmath>
#include <vector>
#include<string>
#include<cstring>
#include<queue>

using namespace std;

int n,m,T;
int ch[1005][1005];
int vis[1005][1005];
int dx[4] = {1,0,-1,0};
int dy[4] = {0,1,0,-1};

struct node{
    int x,y,dir,step;//记录方向,步数
};


int bfs(int x1,int y1,int x2,int y2){
    queue<node> q;
    node s,temp;
    s.x = x1;
    s.y = y1;
    s.step = 0;
    s.dir = -1;
    q.push(s);

    while(!q.empty()){
        temp = q.front();
        q.pop();

        if(temp.x==x2 && temp.y==y2 && temp.step<=2)
            return 1;
        for(int i=0;i<4;i++){
            s = temp;
            s.x+=dx[i];
            s.y+=dy[i];

            if(s.x<1 || s.y<1 || s.x>n || s.y>m)
                continue;
            if(ch[s.x][s.y]==0 ||  (s.x==x2 && s.y==y2)){
                if(s.dir!=-1){
                    if(s.dir!=i){
                        s.dir = i;
                        s.step++;
                    }
                }else
                    s.dir = i;

                if(s.step > 2)
                    continue;

                if(s.step<=vis[s.x][s.y]){
                    vis[s.x][s.y] = s.step;
                    q.push(s);
                }
            }
        }

    }
    return 0;
}


int main(){
    while(~scanf("%d%d",&n,&m)){

        if(n==0)
            break;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                cin>>ch[i][j];
        scanf("%d",&T);
        while(T--){
            memset(vis,10,sizeof(vis));//1也行
            int x1,y1,x2,y2,ans;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            if(!ch[x1][y1] || !ch[x2][y2] || ch[x1][y1]!=ch[x2][y2] || (x1==x2 && y1==y2))
                ans=0;
            else
                ans = bfs(x1,y1,x2,y2);

            if(ans)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;

        }

    }

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值