https://pintia.cn/problem-sets/994805342720868352/problems/994805380754817024
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
题目大意:使用栈来模拟中序遍历,从中获取前序和中序遍历结果,求后序遍历,输出的最后一个元素后面没有空格。
算法思路:第一种就是构建二叉树,然后后序遍历,第二种也就是这里介绍的,利用前序和中序遍历直接得到后序遍历,因为本题没让我们一定要构建出二叉树。
#include<bits/stdc++.h>
using namespace std;
vector<int> preorder;
vector<int> inorder;
vector<int> postorder;
void solution(int preL, int inL, int postL, int n) {
if (n==0) return;
if (n==1) {
postorder[postL] = preorder[preL];
return;
}
int root = preorder[preL];
postorder[postL + n - 1] = root;
int L = 0,R =0;
for (int i = 0; i < n; i++) {
if (inorder[inL + i] == root) {
L = i;
R = n - L - 1;
break;
}
}
solution(preL + 1, inL, postL, L);
solution(preL + L + 1, inL + L + 1, postL + L, R);
return;
}
int main() {
int n;
cin >> n;
postorder = vector<int>(n, 0);
string s;
int k;
stack<int> stk;
for (int i = 0; i < 2 * n; i++) {
cin >> s ;
if (s == "Push") {
cin >> k;
preorder.push_back(k);
stk.push(k);
}
else {
inorder.push_back(stk.top());
stk.pop();
}
}
solution(0, 0, 0, n);
cout << postorder[0];
for (int i = 1; i < n; i++) {
cout << " " << postorder[i];
}
cout << endl;
//system("pause");
return 0;
}
//使用类封装了一下,程序更清晰
#include<bits/stdc++.h>
using namespace std;
class Solution {
public:
Solution(int n){
this->n = n;
postorder = vector<int>(n, 0);
}
void getInput() {
string s;
int k;
stack<int> stk;
for (int i = 0; i < 2 * n; i++) {
cin >> s;
if (s == "Push") {
cin >> k;
preorder.push_back(k);
stk.push(k);
}
else {
inorder.push_back(stk.top());
stk.pop();
}
}
}
void getPost(int preL, int inL, int postL, int n) {
if (n == 0) return;
if (n == 1) {
postorder[postL] = preorder[preL];
return;
}
int root = preorder[preL];
postorder[postL + n - 1] = root;
int L = 0, R = 0;
for (int i = 0; i < n; i++) {
if (inorder[inL + i] == root) {
L = i;
R = n - L - 1;
break;
}
}
getPost(preL + 1, inL, postL, L);
getPost(preL + L + 1, inL + L + 1, postL + L, R);
return;
}
void getPrint() {
cout << postorder[0];
for (int i = 1; i < n; i++) {
cout << " " << postorder[i];
}
cout << endl;
}
private:
vector<int> preorder;
vector<int> inorder;
vector<int> postorder;
int n;
};
int main() {
int n;
cin >> n;
Solution sol(n);
sol.getInput();
sol.getPost(0, 0, 0, n);
sol.getPrint();
return 0;
}