给定一个插入序列就可以唯一确定一棵二叉搜索树。然而,一棵给定的二叉搜索树却可以由多种不同的插入序列得到。例如分别按照序列{2, 1, 3}和{2, 3, 1}插入初始为空的二叉搜索树,都得到一样的结果。于是对于输入的各种插入序列,你需要判断它们是否能生成一样的二叉搜索树。
输入格式:
输入包含若干组测试数据。每组数据的第1行给出两个正整数N (≤10)和L,分别是每个序列插入元素的个数和需要检查的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列。最后L行,每行给出N个插入的元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。
输出格式:
对每一组需要检查的序列,如果其生成的二叉搜索树跟对应的初始序列生成的一样,输出“Yes”,否则输出“No”。
输入样例:
4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0
输出样例:
Yes
No
No
#include<bits/stdc++.h>
using namespace std;
struct TreeNode{
int data;
TreeNode* left;
TreeNode* right;
TreeNode(int x):data(x),left(NULL),right(NULL) {}
};
TreeNode* insert(TreeNode* BST,const int& x){
if(BST==NULL){
BST=new TreeNode(x);
}else{
if(x<BST->data){
BST->left=insert(BST->left,x);
}else if(x>BST->data){
BST->right=insert(BST->right,x);
}
}
return BST;
}
TreeNode* buildTree(const int& n){
int x;
TreeNode* BST=NULL; //这个BST必须初始化为NULL,因为第一次调用insert是作为参数的
for(int i=0;i<n;i++){
cin>>x;
BST=insert(BST,x);
}
return BST;
}
bool isSameBST(TreeNode* t1,TreeNode* t2){
if(t1==NULL && t2==NULL) return true;
if((t1==NULL && t2!=NULL) || (t1==NULL && t2!=NULL)) return false;
if(t1->data!=t2->data) return false;
return isSameBST(t1->left,t2->left) && isSameBST(t1->right,t2->right);
}
void deleteTree(TreeNode* tree){
if(tree->left) deleteTree(tree->left);
if(tree->right) deleteTree(tree->right);
delete(tree);
}
int main(){
vector<string> res;
int n,l;
TreeNode* BST;
cin>>n;
while(n){
cin>>l;
BST=buildTree(n);
TreeNode* tmpBST;
for(int i=0;i<l;i++){
tmpBST=buildTree(n);
if(isSameBST(BST,tmpBST)) res.push_back("Yes");
else res.push_back("No");
deleteTree(tmpBST);
}
deleteTree(BST);
cin>>n;
}
for(auto x : res) cout<<x<<endl;
return 0;
}