Charlie's Change(完全背包1记录路径优化)

Charlie's Change


Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task.

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly.
Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie’s valet. The last line of the input contains five zeros and no output should be generated for it.
Output

For each situation, your program should output one line containing the string “Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.”, where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output “Charlie cannot buy coffee.”.
Sample Input

12 5 3 1 2
16 0 0 0 1
0 0 0 0 0
Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.

 

题意:题目大概讲的就是有1分,5分,10分,25分的硬币,分别有C1,C2,C3,C4个,咖啡价格为P,求凑成p所用的最大硬币数。(完全背包,再记录一下路径)

开几个数组,分别记录容量j里的所用硬币数,使用某种分值的硬币数(判断是否超出题目所给的数量),以及分隔情况(求解每种分值的硬币数),然后emmmmmmm,好难讲,直接看代码把

 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define INF -9999999
#define  maxn 100000
using namespace std;
int dp[maxn];
int path[maxn];
int used[maxn];  
int sum[26];
int main(){
	int p,num[4];
	int v[4]={1,5,10,25};
	while(scanf("%d%d%d%d%d",&p,&num[0],&num[1],&num[2],&num[3])){
		if(!p&&!num[0]&&!num[1]&&!num[2]&&!num[3])return 0;
		memset(path,0,sizeof(path));
		memset(sum,0,sizeof(sum));
		memset(dp,INF,sizeof(dp));
		dp[0]=0;
		path[0]=-1;
		for(int i=0;i<4;i++){
			memset(used,0,sizeof(used));
			for(int j=v[i];j<=p;j++){
				if(dp[j-v[i]]>=0&&dp[j]<dp[j-v[i]]+1&&used[j-v[i]]<num[i]){
					dp[j]=dp[j-v[i]]+1;  // 容量j买了v[i]后的硬币数 
					used[j]=used[j-v[i]]+1;  //容量j买了v[i]后的硬币数 
					path[j]=j-v[i];		//容量j买了v[i]后的容量,记录路径 
				}
			}
		}
		if(dp[p]<0){   //小于0,说明没办法用所给的硬币凑成p 
			printf("Charlie cannot buy coffee.\n"); 
		}
		else{ 
			while(path[p]!=-1){
				sum[p-path[p]]++;  //求每种分值的硬币所用的个数
				p=path[p];
			}
			printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",sum[1],sum[5],sum[10],sum[25]); 
		}
	}
	return 0; 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值