Boring count 窗体移动,尺取法

You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.

Input

In the first line there is an integer T , indicates the number of test cases. 
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K. 

[Technical Specification] 
1<=T<= 100 
1 <= the length of S <= 100000 
1 <= K <= 100000

Output

For each case, output a line contains the answer.

Sample Input

3
abc
1
abcabc
1
abcabc
2

Sample Output

6
15
21

 

#include <iostream>
#include<cstdio>
#include<string.h>
typedef long long ll;
using namespace std;
int main(){
	int T;
	cin>>T;
	char str[100001];
	int n;
	while(T--)
	{
	int sum[40];
	ll ans=0;
	memset(sum,0,sizeof(sum));
	cin>>str>>n;
	int pos=0;
	int l=strlen(str);
	for(int i=0;i<l;i++)
	{
		sum[str[i]-'a']++;
		while(sum[str[i]-'a']>n)
		{
		sum[str[pos]-'a']--;
		pos++;
		}
		ans=ans+i-pos+1;
	}
		printf("%lld\n",ans);
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值