HDU 1495 非常可乐(广搜)

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string.h>
#include<cstring>
#include<queue>
using namespace std;
int b[3],book[101][101][101]={0},half;
struct node{
    int cur[3],s;
}p,temp;
void bfs()
{
    queue<node> q;
    p.cur[0] = b[0];
    p.cur[1] = p.cur[2] = p.s = 0;
    q.push(p);
    while(!q.empty())
    {
        p = q.front();
        q.pop();
        for(int i = 0; i<3;i++)
        {
            if(p.cur[i]>0)
            {
                for(int j = 0;j<3;j++)
                {
                    temp = p;
                    if(i==j)continue;
                    if(temp.cur[i]>b[j]-temp.cur[j])
                    {
                        temp.cur[i] -= b[j] - temp.cur[j];
                        temp.cur[j]=b[j];
                    }
                    else
                    {
                        temp.cur[j]+=temp.cur[i];
                        temp.cur[i] = 0;
                    }
                    if(!book[temp.cur[0]][temp.cur[1]][temp.cur[2]])
                    {
                       book[temp.cur[0]][temp.cur[1]][temp.cur[2]]=1;
                       temp.s++;
                       if((temp.cur[0]==half&&temp.cur[1]==half)||(temp.cur[0]==half&&temp.cur[2]==half)||(temp.cur[1]==half&&temp.cur[2]==half))
                       {
                           cout<<temp.s<<endl;
                           return ;
                       }
                       q.push(temp);
                    }
                }
            }
        }
    }
}
int main(){
    while(cin>>b[0]>>b[1]>>b[2],b[0]+b[1]+b[2])
    {
        memset(book,0,sizeof(book));
        book[b[0]][b[1]][b[2]]=1;
        if(b[0]%2!=0)cout<<"No"<<endl;
        else{
            half=b[0]/2;bfs();
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值