BFS经典题 迷宫

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路 : 递归记录路径!

#include<iostream>
#include<queue>
using namespace std;
int dx[] = {-1,0,1,0};
int dy[] = {0,1,0,-1};
int maze[5][5];
struct node{
	int x,y;
}; 
vector<vector<node> > pre(5,vector<node>(5));
void print(int x,int y){
	if(x||y)   print(pre[x][y].x,pre[x][y].y);
	printf("(%d, %d)\n",x,y);
}
void bfs(){
	queue<node> q;
	node now,next;
	now.x = 0,now.y = 0;
	maze[0][0] = 1;
	q.push(now);
	while(q.size()){
		now = q.front();
		q.pop();
		for(int i = 0;i < 4;i ++){
			next.x = now.x + dx[i],next.y = now.y + dy[i];
			if(next.x >= 0 && next.x < 5 && next.y >= 0 && next.y < 5 && !maze[next.x][next.y]){
				pre[next.x][next.y].x = now.x,pre[next.x][next.y].y = now.y;
				q.push(next);
				maze[next.x][next.y] = 1;
				if(next.x == 4 && next.y == 4){
					print(4,4);
					return;
				}
			}
		}
	}
}
int main()
{
	for(int i = 0;i < 5;i ++){
		for(int j = 0;j < 5;j ++){
			cin>>maze[i][j];
		}
	}
	bfs();
 	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值