[蓝桥杯][算法提高VIP]学霸的迷宫

题目描述

学霸抢走了大家的作业,班长为了帮同学们找回作业,决定去找学霸决斗。但学霸为了不要别人打扰,住在一个城堡里,城堡外面是一个二维的格子迷宫,要进城堡必须得先通过迷宫。因为班长还有妹子要陪,磨刀不误砍柴功,他为了节约时间,从线人那里搞到了迷宫的地图,准备提前计算最短的路线。可是他现在正向妹子解释这件事情,于是就委托你帮他找一条最短的路线。

输入

第一行两个整数n, m,为迷宫的长宽。
接下来n行,每行m个数,数之间没有间隔,为0或1中的一个。0表示这个格子可以通过,1表示不可以。假设你现在已经在迷宫坐标(1,1)的地方,即左上角,迷宫的出口在(n,m)。每次移动时只能向上下左右4个方向移动到另外一个可以通过的格子里,每次移动算一步。数据保证(1,1),(n,m)可以通过。

输出

第一行一个数为需要的最少步数K。
第二行K个字符,每个字符∈{U,D,L,R},分别表示上下左右。如果有多条长度相同的最短路径,选择在此表示方法下字典序最小的一个。

样例输入

3 3
001
100
110

样例输出

4
RDRD

提示

#include<iostream>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
int m,n,len;
int dx[] = {1,0,0,-1};
int dy[] = {0,-1,1,0};
char dir[] = {'D','L','R','U'};
vector<string> v;
string ans;
struct node{
	int x;
	int y;
	string path;
};
void BFS(int x,int y){
	node now,next;
	now.x = x,now.y = y;
	v[now.x][now.y] = '1';
	queue<node> q;
	q.push(now);
	while(q.size()){
		now = q.front();
		q.pop();
		for(int i = 0;i < 4;i ++){
			next.x = now.x + dx[i],next.y = now.y + dy[i],next.path = now.path;
			if(next.x >= 0 && next.x < m && next.y >= 0 && next.y < n && v[next.x][next.y] == '0'){
				next.path += dir[i];
				q.push(next);
				v[next.x][next.y] = '1';
				if(next.x == m - 1 && next.y == n - 1){
					ans = next.path;
					return;
				}
		   }
	    }	
	}
}
int main()
{
	string s;
	cin>>m>>n;
	len = m * n;
	for(int i = 0;i < m;i ++){
		cin>>s;
		v.push_back(s);
	}
	BFS(0,0);
	cout<<ans.length()<<endl<<ans<<endl;
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值