PAT甲级1002C++实现

题目:
1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​​​ N​2​​ a​N2 … NK​​ a​N​K where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
思路:
多项式相加,考虑到多项式的性质,是由map来实现。以指数作为Key,系数作为Value。以不为零项数作为循环次数,用map::insert()将单项式添加到map中。遇到原先没有的,就插入,遇到已经出现的,将系数加到原先的系数上。最后使用逆序迭代器输出。
问题:
对map的迭代器进行>=,<=,<,>操作符似乎是错误的(重新验证后是合法的),所以只能使用逆序迭代器。迭代器-1表达式似乎也是非法(是非法的)。某项系数计算结果为0时,仍会输出,做特殊处理。
代码:

#include<map>			// use map to save poly
#include<iostream>
using namespace std;
int main()
{
	map<int, double> poly;
	int i;
	cin >> i;
	for (int j = 0; j < i; ++j) {
		int exp;
		double coe;
		cin >> exp >> coe;
		if ( !poly.insert(make_pair(exp, coe)).second) {
			poly[exp] = poly[exp] + coe;
		}
	}
	cin >> i;
	for (int j = 0; j < i; ++j) {
		int exp;
		double coe;
		cin >> exp >> coe;
		if (!poly.insert(make_pair(exp, coe)).second) {
			poly[exp] = poly[exp] + coe;
		}
	}
	int count = 0;
	for (map<int, double>::reverse_iterator iter = poly.rbegin(); iter != poly.rend(); ++iter) {
		if ((*iter).second != 0) {
			++count;
		}
	}
	cout << count;
	for (map<int, double>::reverse_iterator iter = poly.rbegin(); iter != poly.rend(); ++iter) {
		if ((*iter).second!=0) {
			printf(" %d %.1lf", (*iter).first, (*iter).second);
		}
	}
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值