习题7-7 字符串替换

习题7-7 字符串替换
Description

本题要求编写程序,将给定字符串中的大写英文字母按以下对应规则替换:

原字母对应字母
AZ
BY
CX
DW
XC
YB
ZA

Input
输入在一行中给出一个不超过80个字符、并以回车结束的字符串。

Output
输出在一行中给出替换完成后的字符串。

Sample Input 1

Only the 11 CAPItaL LeTtERS are replaced.
Sample Output 1

Lnly the 11 XZKRtaO OeGtVIH are replaced.

#include <stdio.h>
#include <string.h>
int main(int argc, char const *argv[])
{
	/* code */
	char str[80];
	int len;
	gets(str);
	len=strlen(str);
	int i=0;
	for (i = 0; i < len; ++i)
	{
		/* code */
		if (str[i]>='A'&&str[i]<='Z')
		{
			/* code */
			str[i]='A'+'Z'-str[i];
		}
	}
	printf(str);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值