《数据结构》题目集--------------HDU 1711 Number Sequence

题目

题目:

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output

6
-1

思路

KMP 模板题,懂得KMP基本操作就可以做出来 ;样例输入第一行为测试的对数,第二行分别为主串和模式串的字符个数。

代码

// kmp 模板题·.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include <string>
#include<iostream>
using namespace std;

int str[1000010];
int ptr[10010];
int l_str, l_ptr;
void get_next(int ptr[], int*next)
{
	int j, k;
	j = 0;
	k = -1;
	next[0] = -1;
	while(j < l_ptr)
	{
		if (k == -1|| ptr[j] == ptr[k])
		{
			++j;
			++k;
			next[j] = k;
		}
		else {
			k = next[k];
		}

	}
}
int kmp(int str[], int ptr[])
{
	int i, j;
	int next[10010];
	get_next(ptr, next);
	i = 0;
	j = 0;
	while (i < l_str && j < l_ptr)
	{
		if (j == -1 || str[i] == ptr[j])
		{
			++i;
			++j;
		}
		else
		{
			j = next[j];
		}
	}
	if (j >=l_ptr)
	{
		return i - l_ptr;
	}
	else
		return -1;
}

int main()
{
	int i, t, k;
	cin >> t;
	while (t--)
	{
		cin >> l_str >> l_ptr;
		for (int i = 0; i < l_str; i++)
		{
			cin >> str[i];
		}
		for (int i = 0; i < l_ptr; i++)
		{
			cin >> ptr[i];
		}
		k = kmp(str, ptr);
		if (k >= 0)
			cout << k + 1 << endl;
		else
			cout << -1 << endl;
	}

    return 0;
}


结果

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值