1021 Deepest Root (25 分)

1021 Deepest Root (25 分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 题意:给出n个结点,给出n-1条边,判断他是不是树(此时连通块为1,则该图为树),如果是树则要找它有最大高度的根结点,找的方法是选择任意一个结点,从该节点开始遍历整棵树,获得达到最大高度的顶点集合A,然后从集合A中任意一个结点出发遍历整棵树,获得的最大高度的结点集合B,A和B的并集就为解,用set保存既可以去重复,又可以排序。

思路:1进行第一次dfs求连通集的个数,并且得到集合A

#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;

vector<vector<int> > G;
bool vis[10010];
int maxheight=0,n;
vector<int> temp;

void dfs(int v,int height)
{
	if(height>maxheight){
		temp.clear();
		maxheight=height;
		temp.push_back(v);
	}
	else if(height==maxheight){
		temp.push_back(v);
	}
	vis[v]=true;
	for(int i=0;i<G[v].size();i++){
		if(vis[G[v][i]]==false){
			dfs(G[v][i],height+1);
		}
	}
}

int main()
{
	int v,u,s1=0,cnt=0;
	set<int> ans;
	scanf("%d",&n);
	G.resize(n+1);//没分配大小会有段错误 
	for(int i=0;i<n-1;i++){
		scanf("%d %d",&v,&u);
		G[v].push_back(u);
		G[u].push_back(v);
	}
	for(int i=1;i<=n;i++){
		if(vis[i]==false){
			dfs(i,1);
			if(i==1){
				if(temp.size()!=0){
					s1=temp[0];
				} 
				for(int j=0;j<temp.size();j++){
					ans.insert(temp[j]);
				}
			}
			cnt++;
		} 
	}
	if(cnt>1){
		printf("Error: %d components\n",cnt);
	}
	else{
		temp.clear();
		fill(vis,vis+10010,false);
		maxheight=0;
		dfs(s1,1);
		for(int i=0;i<temp.size();i++){
			ans.insert(temp[i]);
		}
		for(auto it=ans.begin();it!=ans.end();it++){
			printf("%d\n",*it);
		}
	}
	return 0;
}

2判断是否为树。

3如果为树则进行第二次dfs,以temp中的第一个结点开始进行dfs(记得初始化),得出集合B。

细节:1如果使用使用邻接矩阵会超时(10^4)。

2G.resize()分配值要为n+1,否则会有段错误。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值