1021 Deepest Root (25)(25 分)(C++)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

题目大意:给一个图,首先判断是否为连通图,若非连通图,则分为几个部分?若是连通图,那么以哪些节点为根节点建造的树度最大,输出这几个根节点。

解题思路:读题我们不难发现,判断是否为连通图以及计算以某个节点为根节点的树的度,都可以用DFS解决。首先第一遍DFS判断是否为连通图,思想在之前的题目中也有体现。若为连通图,则我们输出所有达到maxheight的节点。

一开始,我在判断时,以每个结点为根节点都计算了一遍度。。。

还有一个测试点超时了。

for(i=1;i<=n;i++){
        fill(visit,visit+10010,false);
        dfs(i,1);
    }

其实大可不必如此,想想我们在判断是否为连通图的时候,我们就已经得到了以0为根节点,最深的根节点们,想一想,如果我们以这些节点为根节点建树,得到的深度是不是也是最深。所以,只要再以第一遍存储下的节点进行DFS即可,是不是省了很多时间。

#include <iostream>
#include <vector>
#include <set>
using namespace std;
vector<vector<int>>tree;
int n, cnt = 0, maxlevel = -1;
bool visit[10005];
set<int>ans, tempans;
void dfs(int index, int level){
	visit[index] = true;
	if(maxlevel < level){
		maxlevel = level;
		ans.clear();
		ans.insert(index);
	}
	else if(maxlevel == level)
		ans.insert(index);
	for(int i = 0; i < tree[index].size(); ++ i)
		if(visit[tree[index][i]] == false)
			dfs(tree[index][i], level + 1);
}
int main(){
	scanf("%d",&n);
	tree.resize(n + 1);
	for(int i = 1; i < n; ++ i){
		int a, b;
		scanf("%d %d",&a,&b);
		tree[a].push_back(b);
		tree[b].push_back(a);
	}
	for(int i = 1; i <= n; ++ i){
		if(visit[i] == false){
			++ cnt;
			dfs(i,0);
		}
	}
	if(cnt == 1){
		int temp = *ans.begin();
		tempans = ans;
		ans.clear();
		fill(visit, visit + 10005, false);
		dfs(temp, 0);
		for(auto it = tempans.begin(); it != tempans.end(); ++ it)
			ans.insert(*it);
		for(auto it = ans.begin(); it != ans.end(); ++ it)
			printf("%d\n", *it);
	}
	else
		printf("Error: %d components", cnt);
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值