1051 Pop Sequence (25 分)

1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

.题意:用一个容量为m的堆栈,把1,2.....,n依次入栈,随机出栈,给出一系列出栈顺序,问是否这些出栈顺序是否可能。

思路:判断堆栈顶的数与当前的数是否相等。堆栈里数的量大过容量m,则false。用数组存取所给的序列。堆栈直接用stl实现。

细节:1.要在每次序列入栈前清空堆栈。

2.!st.empty()不等价st.empty()!=0(这里零并不能表示否的意思,太蠢了)。

#include <iostream>
#include <stack>
#include <algorithm>
using namespace std;

int arr[1010];
int main()
{
	int m,n,k;
	scanf("%d %d %d",&m,&n,&k);
	stack<int> st;
	
	for(int i=0;i<k;i++){
		while(!st.empty()){//清空栈 
			st.pop();
		}
		for(int j=1;j<=n;j++){//读入数据 ,从1开始 
			scanf("%d",&arr[j]);
		}
		int flag=true;
		int cnt=1;//指出出栈序列中待出栈的元素 
		for(int j=1;j<=n;j++){
			st.push(j);
			if(st.size()>m){//栈中元素大于m,则序列非法 
				flag=false;
				break;
			}
			while(!st.empty()&&st.top()==arr[cnt]){//栈顶元素与出栈序列当前位置元素相同 
				cnt++;
				st.pop();//出栈 
			}
		}
		if(!st.empty()){//因为false是,栈一定不空 
			printf("NO\n");
		}
		else{
			printf("YES\n");
		} 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值