HDU 1506 Largest Rectangle in a Histogram(单调栈)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
在这里插入图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000

自己一开始用一次单调栈来求,先单调增,不行;又单调减,也不行。。。果断放弃,看题解,代码抄下来有一点明白了。大体思路是这样的,先从左到右遍历一次,求出每个点向左扩展的最大距离,比如说l[5]=2是指5号点向左一直到2号点都比5号高。然后在从右向左遍历一次,求出每个点向右扩展的最大距离。这样以每个点为最低点向左向右的扩展都能求出来,在计算一下求最大值就好了。

#include <iostream>
#include <cstdio>
#include <stack>
#include <algorithm>
using namespace std;

int a[100005], l[100005], r[100005];
int main()
{
	int n;
	stack<int> s;
	while (scanf("%d", &n)!=EOF && n){
		for (int i=1; i<=n; i++)
			scanf("%d", &a[i]);
		
		while (!s.empty())	s.pop();
		for (int i=1; i<=n; i++){
			while (s.size() && a[s.top()]>=a[i])
				s.pop();
			if (s.empty())
				l[i]=0;
			else
				l[i]=s.top();
			s.push(i);
		}
		
		while (!s.empty())	s.pop();
		for (int i=n; i>=1; i--){
			while (s.size() && a[s.top()]>=a[i])
				s.pop();
			if (s.empty())
				r[i]=n+1;
			else
				r[i]=s.top();
			s.push(i);
		}
		
		long long ans=0;
		for (int i=1; i<=n; i++)
			ans=max(ans, (long long)a[i]*(r[i]-l[i]-1));
		printf("%lld\n", ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

H4ppyD0g

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值