hdu1506 Largest Rectangle in a Histogram(单调栈)

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

这里写图片描述

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
 

Sample Output
  
  
8
4000
 
Statistic |  Submit |  Discuss | Note


分析:
这道题就是寻找区间最小值

tip

最后要把栈中的元素都弹出,进行统计

//这里写代码片
#include<cstdio>
#include<cstring>
#include<iostream>
#define ll long long

using namespace std;

const int N=100010;
int S[N],l[N],r[N],n,a[N];
ll ans=0;

void cal(int i)
{
    ll tt=(ll)(r[i]-l[i]+1)*a[i];
    if (tt>ans) ans=tt; 
}

int main()
{
    while (scanf("%d",&n)!=EOF&&n)
    {
        int x,top=0;
        ans=0;
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            l[i]=i; r[i]=i;
            while (top>=1&&a[S[top]]>=a[i])
            {
                r[S[top]]=i-1;
                cal(S[top]);
                top--;
            }
            l[i]=S[top]+1;
            S[++top]=i;
        }
        while (top)
        {
            cal(S[top]);
            r[S[top-1]]=r[S[top]];
            top--;
        }
        printf("%lld\n",ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值