POJ 3494 Largest Submatrix of All 1’s(单调栈)

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.
Input
The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.
Output
For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.
Sample Input
2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0
Sample Output
0
4

首先找每个点向上的最大高度,然后再对每个点向左扩展,再向右扩展。
找每个点向左向右方向第一个比它小的位置是一个单调减栈。

#include<iostream>
#include<cstdio>
#include<stack>
#include <cstring>
#include<algorithm>
using namespace std;
 
int m,n;
int a[2005][2005];
int u[2005][2005];
int l[2005][2005],r[2005][2005];
 
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF){
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&a[i][j]);
            }
        }
    	stack<pair<int,int> > s;
    	memset(u,0,sizeof(u));
    	for(int i=1;i<=m;i++){//求出每个点向上连续的最大长度 
    	    for(int j=1;j<=n;j++){
    	        if(a[i][j]==0) u[i][j]=0;
    	        else u[i][j]=u[i-1][j]+1;
    	    }
    	}
    	for(int i=1;i<=m;i++){
    	    while(!s.empty()) s.pop();
    	    for(int j=1;j<=n;j++){
    	        while(!s.empty()&&s.top().first>=u[i][j]){//找左边第一个比它小的位置 
    	            s.pop();
    	        }
    	        if(s.empty()) l[i][j]=1;
    	        else l[i][j]=s.top().second+1;
    	        s.push(pair<int,int>(u[i][j],j));
    	    }
    	}
 	
 	   	for(int i=1;i<=m;i++){
 	       	while(!s.empty()) s.pop();
 	       	for(int j=n;j>=1;j--){
 	           	while(!s.empty()&&s.top().first>=u[i][j]){
 	               s.pop();
 	           	}
 	           	if(s.empty()) r[i][j]=m;
 	           	else r[i][j]=s.top().second-1;
 	           	s.push(pair<int,int>(u[i][j],j));
 	    	}
 	   	}
 	
 	   	int res=0;
 	   	for(int i=1;i<=m;i++){
 	       	for(int j=1;j<=n;j++){
 	           	res=max(res,u[i][j]*(r[i][j]-l[i][j]+1));
 	       	}
 	   	}
		printf("%d\n",res);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

H4ppyD0g

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值