6.25AtCoderABC257E - Addition and Multiplication 2题解

6.25AtCoderABC257E - Addition and Multiplication 2题解

题目描述

链接

AtCoderABC257E - Addition and Multiplication 2

文字描述

E - Addition and Multiplication 2 /
Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 500 points

Problem Statement
Takahashi has an integer x. Initially, x=0.

Takahashi may do the following operation any number of times.

Choose an integer i (1≤i≤9). Pay C
i

yen (the currency in Japan) to replace x with 10x+i.
Takahashi has a budget of N yen. Find the maximum possible value of the final x resulting from operations without exceeding the budget.

Constraints
1≤N≤10
6

1≤C
i

≤N
All values in input are integers.
Input
Input is given from Standard Input in the following format:

N
C
1

C
2

… C
9

Output
Print the answer.

Sample Input 1
Copy
5
5 4 3 3 2 5 3 5 3
Sample Output 1
Copy
95
For example, the operations where i=9 and i=5 in this order change x as:

0→9→95.

The amount of money required for these operations is C
9

+C
5

=3+2=5 yen, which does not exceed the budget. Since we can prove that we cannot make an integer greater than or equal to 96 without exceeding the budget, the answer is 95.

Sample Input 2
Copy
20
1 1 1 1 1 1 1 1 1
Sample Output 2
Copy
99999999999999999999
Note that the answer may not fit into a 64-bit integer type.

题目分析

  1. 此题想让数最大,最大首先保证位数最大,即用最小的数把k除向下取整的值就是,最大数的数位长度。
  2. 在位数最大的基础上,保证首位尽可能的大,但不能影响到取得数位长度。(经典的贪心)
  3. 由此推出每次先从首位挑尽可能大的,判断条件:当取到这位是其余为确定位能不能都填最小的(数位不变)。

代码实现

#include<bits/stdc++.h>
using namespace std;

int k,mi=1e9,n;
int a[100];
int main(){
	scanf("%d",&k);
	for(int i=1;i<=9;i++){
		scanf("%d",&a[i]);
		mi=min(mi,a[i]);
	}
	n=k/mi;
	for(int i=1;i<=n;i++){
		for(int j=9;j>=1;j--){
			if(k-a[j]>=mi*(n-i)){
				k-=a[j];
				printf("%d",j);
				break;
			}
		}
	}
	printf("\n");
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Yxz_

我只是一名ssfoier

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值