POJ3278抓住那头牛题解

POJ3278抓住那头牛题解

题目

链接

http://poj.org/problem?id=3278

字面描述

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 201124 Accepted: 61178
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source

USACO 2007 Open Silver

代码实现

建议使用BFS,数据量大DFS超时

#include<cstdio>
#include<string.h>
using namespace std;

const int maxn=1e5+10; 
int n,k;
int dis[maxn],que[maxn];
bool vis[maxn];
inline bool inbound(int x){return x>=0&&x<=100000;}
int main(){
	scanf("%d%d",&n,&k);
	int head=0,tail=0;
	que[tail++]=n;
	vis[n]=true;
	while(head<tail){
		int x=que[head++];
		if(x==k)break;
		if(inbound(x+1)&&!vis[x+1]){
			que[tail++]=x+1;
			vis[x+1]=true;
			dis[x+1]=dis[x]+1;
		}
		if(inbound(x-1)&&!vis[x-1]){
			que[tail++]=x-1;
			vis[x-1]=true;
			dis[x-1]=dis[x]+1;
		}
		if(inbound(2*x)&&!vis[2*x]){
			que[tail++]=2*x;
			vis[2*x]=true;
			dis[2*x]=dis[x]+1;
		}
	}
	printf("%d\n",dis[k]);
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

materialistOier

我只是一名ssfoier

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值