P1797重型运输 题解

P1797重型运输 题解

题目

链接

http://poj.org/problem?id=1797

字面描述

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 82802 Accepted: 19972
Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5
Sample Output

Scenario #1:
4
Source

TUD Programming Contest 2004, Darmstadt, Germany

思路

我们只需要使用Dijkstra的堆优化,保证时间复杂度的充裕,在把dis[]数组记录成最小承重的最大值即可

代码实现

#include<cstdio>
#include<string.h>
#include<queue>
using namespace std;

const int maxn=1e3+10;
const int inf=2e9;
int t,n,m,tot;
int head[maxn],dis[maxn];
struct node{
	int v,w,nxt;
}e[maxn*maxn];
bool vis[maxn];
inline void add(int u,int v,int w){
	e[++tot].v=v;
	e[tot].w=w;
	e[tot].nxt=head[u];
	head[u]=tot;
}
inline void dijstra(int u){
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	priority_queue< pair<int,int> >q;
	dis[u]=inf;
	q.push(make_pair(dis[u],u));
	while(!q.empty()){
		int x=q.top().second;
		q.pop();
		if(vis[x]){
			if(x==n)return ;
			else continue;
		}
		vis[x]=true;
		for(int i=head[x];i;i=e[i].nxt){
			int v=e[i].v;
			if(vis[v])continue;
			if(dis[v]<min(dis[x],e[i].w)){
				dis[v]=min(dis[x],e[i].w);
				q.push(make_pair(dis[v],v));
			}
		}
	}
}
int main(){
	scanf("%d",&t);
	int T=t;
	while(t--){
		printf("Scenario #%d:\n",T-t);
		memset(head,0,sizeof(head));
		scanf("%d%d",&n,&m);
		for(int i=1;i<=m;i++){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			add(a,b,c);
			add(b,a,c);
		}
		//for(int i=1;i<=tot;i++)printf("%d %d %d\n",e[i].v,e[i].w,e[i].nxt);
		for(int i=1;i<=n;i++)dis[i]=inf;
		dijstra(1);
		printf("%d\n\n",dis[n]);
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Yxz_

我只是一名ssfoier

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值