CF1714A Everyone Loves to Sleep 题解

题目

链接

https://www.luogu.com.cn/problem/CF1714A

字面描述

题面翻译

题目描述

Vlad和其他人一样,非常喜欢睡觉。

Vlad每天都要做 n n n 件事,每件事在特定时间。对于这些事情中的每一件,他都定了一个闹钟,其中第 i i i 个在 h i h_i hi m i m_i mi 分被触发( 0 ≤ h i < 24 , 0 ≤ m i < 60 ) 0\le h_i<24,0\le m_i<60) 0hi<24,0mi<60

Vlad使用24小时时间格式,所以12:59之后是13:00,23:59后是00:00。

Vlad在H时M分睡觉( 0 ≤ H < 24 , 0 ≤ M < 60 0 \le H < 24, 0 \le M < 60 0H<240M<60)。

他要你回答:在下一个闹钟响之前,他能睡多久。

如果在他上床睡觉的时候有任何闹钟响起,那么他将睡0小时0分钟。

输入格式

输入数据的第一行包含一个整数 t t t ( 1 ≤ t ≤ 100 1 \le t \le 100 1t100) — 测试中测试用例的数量。

每组测试用例的第一行包含三个整数 n n n , H H H M M M ($ 1 \le n \le 10, 0 \le H < 24, 0 \le M < 60$) — 闹钟的数量和Vlad上床睡觉的时间。

以下 n n n 行各包含两个数字 h i h_i hi m i m_i mi ( 0 ≤ h i < 24 , 0 ≤ m i < 60 0 \le h_i < 24, 0 \le m_i < 60 0hi<240mi<60) — 每个闹钟响的时间。两个或多个闹钟可以同时响起。描述时间的数字不包含前导零。

输出格式

输出 t t t 行,每行都包含相应测试用例的答案。

作为答案,输出两个数字 - Vlad将分别睡觉的小时数和分钟数。如果在他上床睡觉的时候有任何闹钟响起,答案将是 0   0 0\ 0 0 0

样例解释

对于第一个测试用例,Vlad上床后第一个响的闹钟是8:00的。

对于第二个测试用例,Vlad上床时有闹钟响起。

对于第三个测试用例,Vlad上床后第一个响的闹钟是第二天10:30的。

题目描述

Vlad, like everyone else, loves to sleep very much.

Every day Vlad has to do $ n $ things, each at a certain time. For each of these things, he has an alarm clock set, the $ i $ -th of them is triggered on $ h_i $ hours $ m_i $ minutes every day ( $ 0 \le h_i < 24, 0 \le m_i < 60 $ ). Vlad uses the $ 24 $ -hour time format, so after $ h=12, m=59 $ comes $ h=13, m=0 $ and after $ h=23, m=59 $ comes $ h=0, m=0 $ .

This time Vlad went to bed at $ H $ hours $ M $ minutes ( $ 0 \le H < 24, 0 \le M < 60 $ ) and asks you to answer: how much he will be able to sleep until the next alarm clock.

If any alarm clock rings at the time when he went to bed, then he will sleep for a period of time of length $ 0 $ .

输入格式

The first line of input data contains an integer $ t $ ( $ 1 \le t \le 100 $ ) — the number of test cases in the test.

The first line of the case contains three integers $ n $ , $ H $ and $ M $ ( $ 1 \le n \le 10, 0 \le H < 24, 0 \le M < 60 $ ) — the number of alarms and the time Vlad went to bed.

The following $ n $ lines contain two numbers each $ h_i $ and $ m_i $ ( $ 0 \le h_i < 24, 0 \le m_i < 60 $ ) — the time of the $ i $ alarm. It is acceptable that two or more alarms will trigger at the same time.

Numbers describing time do not contain leading zeros.

输出格式

Output $ t $ lines, each containing the answer to the corresponding test case. As an answer, output two numbers — the number of hours and minutes that Vlad will sleep, respectively. If any alarm clock rings at the time when he went to bed, the answer will be 0 0.

样例 #1

样例输入 #1
3
1 6 13
8 0
3 6 0
12 30
14 45
6 0
2 23 35
20 15
10 30
样例输出 #1
1 47
0 0
10 55

代码实现

一道大模拟题;
最坏时间复杂度为: O ( t ⋅ n ⋅ 1440 ) ≈ 1 e 6 O(t·n·1440) ≈ 1e6 O(tn1440)1e6

#include<bits/stdc++.h> 
using namespace std;

const int maxn=100+10;
int t,n,h,m,ansh,ansm;
int a[maxn][2];
int main(){
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&n,&h,&m);
		for(int i=1;i<=n;i++)scanf("%d%d",&a[i][0],&a[i][1]);
		ansh=ansm=0; 
		while(1){
			bool flag=false;
			for(int i=1;i<=n;i++){
				if(h==a[i][0]&&m==a[i][1]){
					printf("%d %d\n",ansh,ansm);
					flag=true;
					break;
				}
			}
			if(flag)break;
			++m;
			if(m==60)m=0,++h;
			if(h==24)h=0;
			++ansm;
			if(ansm==60)ansm=0,++ansh;
			if(ansh==24)ansh=0;
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

materialistOier

我只是一名ssfoier

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值