10-排序6 Sort with Swap(0, i)

10-排序6 Sort with Swap(0, i)

来自:PTA_数据结构_排序6 Sort with Swap(0, i)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N ( ≤10^5 ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

程序代码:

#include <stdio.h>
#include <stdlib.h>

void solve();

int main()
{
    solve();

    return 0;
}

void solve()
{
    int i, n, tmp, num, *arr;

    scanf("%d", &n);
    arr = (int *)malloc(n * sizeof(int));

    for (i = 0; i < n; ++i) {
        scanf("%d", &arr[i]);
    }

    num = 0; i = 0;
    for (; i < n; ++i) {
        if (arr[i] != i) {
            ++num;  // 假设0不在环里,则此处需要将0额外换入该环中,因此多执行一次swap
            while (arr[i] != i) {
                if (arr[i] == 0)    // 说明0在这个环里,无需额外换入环中,抵消外层的+1计数,并且本身无需再加1,因为包含0的环交换次数等于环长度减1
                    --num;
                else
                    ++num;
                tmp = arr[i];
                arr[i] = i;
                i = tmp;
            }
        }
    }

    printf("%d", num);
    free(arr);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值