PAT甲级刷题记录——1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_numberis a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

思路

这题用C++的字符串类型(string)来做也非常快哈,不过这里对于时间的排序我是用了int型(如果是string的话应该按字典序排序结果也是一样的吧),每次读入三个字符串之后,就把相应的内容给结构体数组,string转int可以用stoi()函数(同理,string转double可以用stod(),这些函数都是C++11的内容),最后先对sign_in_time从早到晚排序,然后输出数组第一个的number就是最早来开门的那个人,然后再对sign_out_time从晚到早排序,输出数组第一个的number就是最晚锁门的那个人。

代码

#include<cstdio>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1010;
struct person{
    string number;
    int sign_in_time;
    int sign_out_time;
}p[maxn];
bool cmp1(person a, person b){//按sign_in从早到晚排序
    return a.sign_in_time<b.sign_in_time;
}
bool cmp2(person a, person b){//按sign_out从晚到早排序
    return a.sign_out_time>b.sign_out_time;
}
int main(){
    int M;
    cin>>M;
    for(int i=0;i<M;i++){
        string tmpnumber, signInTime, signOutTime;
        cin>>tmpnumber>>signInTime>>signOutTime;
        int tmpsignIn = stoi(signInTime);
        int tmpsignOut = stoi(signOutTime);
        p[i].number = tmpnumber;
        p[i].sign_in_time = tmpsignIn;
        p[i].sign_out_time = tmpsignOut;
    }
    sort(p, p+M, cmp1);
    cout<<p[0].number<<" ";
    sort(p, p+M, cmp2);
    cout<<p[0].number;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值