PAT甲级刷题记录——1046 Shortest Distance (20分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105​ ]), followed by N integer distances D1​​ D2​ ⋯ DN​​ , where Di​ is the distance between the i-th and the (i+1)-st exits, and DN​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107​​ .

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

思路

这题之前在Codeup上做过了哈【《算法笔记》学习日记——3.1 简单模拟】,二刷的时候想到了更好的办法,就是说只要预处理顺时针方向的所有路径就可以了,因为一旦算出两个点的其中一条路径长度,那么另外一条路径长度一定是整个圆减去那部分的长度(取补集),而且这个办法可以在输入的时候直接就处理好,所有测试点中最长耗时也就25ms。
虽然现在二刷比起初见的时候做了一下午进步了很多,但是花的时间还是有点久,从拿到题到完全AC花了39分钟(捂脸),应该是脑子抽了叭……

代码

#include<cstdio>
#include<stdlib.h>
#include<math.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 100010;
int data[maxn] = {0};
int shunshizhen[maxn] = {0};
int main(){
    int N;
    scanf("%d", &N);
    int dis = 0;
    for(int i=1;i<=N;i++){
        scanf("%d", &data[i]);
        dis += data[i];
        shunshizhen[i+1] = dis;//shunshizhen[N+1]的意思是顺时针走一圈到原点的距离
    }
    int M;
    scanf("%d", &M);
    for(int i=0;i<M;i++){
        int x, y;
        scanf("%d%d", &x, &y);
        int dis1 = abs(shunshizhen[x]-shunshizhen[y]);
        int dis2 = dis - dis1;//此时的dis就是一圈的总路程
        printf("%d\n", min(dis1, dis2));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值