PAT甲级刷题记录——1090 Highest Price in Supply Chain (25分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105​ ), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si​ is the index of the supplier for the i-th member. Sroot​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010​​ .

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

思路

这题跟【1079 Total Sales of Supply Chain (25分)】差不多哈,不过甚至比那道题简单,因为题目只让你算最高单价,连货物量都没有,也就是说,存储树的结构完全用vector<int>就行了,不需要再定义一个结构体node。

题目大意是这样的:还是给出N个结点,P是单价,r是每次转手价格上升的百分比,然后第二行给出N个数(结点下标从0~N-1),每个数代表着第i个结点的供应商(也就是第i个结点的父亲,比如第一个数是1,就说明1是0的父亲,第二个数是5,就说明5是1的父亲),如果是-1,就代表那个点是根结点(样例中4是根结点,再次提醒,结点编号从0~N-1)。

然后就很简单了,还是用DFS搜叶子结点,搜到叶子就算一下当前的单价,如果比已经记录的最高单价更高,那么更新一下最高单价,并且记录最高单价的叶子数num=1(注意,这里是num=1,不是num++,否则的话每次更新都要++,显然是不对的),另外,如果计算出来的单价和记录的最高单价相同,那么此时num++(之所以这么做是因为我受到了Dijkstra记录最短路径条数的启发:需要更新的时候直接赋值,当相等的时候再进行累加)。

代码

#include<cstdio>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100010;
vector<int> Node[maxn];
double HighestPrice = -1;
int num = 0;//记录最高价格的叶子结点个数
void dfs(int u, int deep, double P, double r){
    if(Node[u].size()==0){
        double price = P*pow(1+r/100, deep);
        if(price>HighestPrice){
            HighestPrice = price;
            num = 1;
        }
        else if(price==HighestPrice) num++;
    }
    for(int i=0;i<Node[u].size();i++){
        int v = Node[u][i];
        dfs(v, deep+1, P, r);
    }
}
int main(){
    int N;
    double P, r;
    scanf("%d%lf%lf", &N, &P, &r);
    int root = 0;
    for(int i=0;i<N;i++){
        int tmp;
        scanf("%d", &tmp);
        if(tmp==-1){
            root = i;
        }
        else{
            Node[tmp].push_back(i);//输入的tmp是供应商,也就是当前结点i的父亲
        }
    }
    dfs(root, 0, P, r);
    printf("%.2f %d", HighestPrice, num);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值