PAT甲级刷题记录——1024 Palindromic Number (25分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010​​ ) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

思路

这题也是很简单哈,直接用大整数的加法一直循环算就行了(不能用long long,因为虽然N还在long long的范围内,但是,谁能保证两个long long反复操作K次之后不溢出呢?对叭,所以必须用大整数加法来做)。至于怎么判断回文串,很简单,把原先的字符串先存个备份,然后把备份reverse()一下(<algorithm>头文件下自带的反转函数),然后再看看这两个字符串是否相等,如果相等,那么就是回文串,如果不等,那么就不是。

注意点】有可能存在输入即是回文串的情况,这个时候就不要加啦,直接特判输出它本身,然后步数是0即可。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 1010;
struct bign{
    int d[maxn];
    int len;
    bign(){
        memset(d, 0, sizeof(d));
        len = 0;
    }
};
bign change(string str){
    bign a;
    a.len = str.length();
    for(int i=str.length()-1, j=0;i>=0, j<str.length();i--, j++){
        a.d[j] = str[i]-'0';
    }
    return a;
}
bign add(bign a, bign b){
    bign c;
    int carry = 0;
    for(int i=0;i<a.len||i<b.len;i++){
        int temp = a.d[i]+b.d[i]+carry;
        c.d[c.len++] = temp%10;
        carry = temp/10;
    }
    if(carry!=0){
        c.d[c.len++] = carry;
    }
    return c;
}
string Bto_string(bign a){
    string tmp;
    for(int i=a.len-1;i>=0;i--){
        tmp += a.d[i]+'0';
    }
    return tmp;
}
int main(){
    string n, tmpN1, tmpN2;
    int K;
    cin>>n>>K;
    tmpN1 = n;
    tmpN2 = tmpN1;
    reverse(tmpN2.begin(), tmpN2.end());
    if(tmpN1==tmpN2){
        cout<<tmpN1<<'\n'<<"0";
    }
    else{
        bign nowN = change(tmpN1);
        bign reN = change(tmpN2);
        int step = 0;
        for(int i=0;i<K;i++){
            bign C = add(nowN, reN);
            tmpN1 = Bto_string(C);
            tmpN2 = tmpN1;
            reverse(tmpN2.begin(), tmpN2.end());
            step++;
            if(tmpN1==tmpN2) break;
            nowN = change(tmpN1);
            reN = change(tmpN2);
        }
        cout<<tmpN1<<'\n'<<step;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值