PAT甲级刷题记录——1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​ k​​ (a​i​​b​i​​ ). Here, as usual, 0≤a​i​​ <b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​ =a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10
​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yesif N is a palindromic number in base b, or Noif not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ … a​0​​ ". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

鸣谢网友“CCPC拿不到牌不改名”修正数据!

思路

这题是一个很简单的进制转换类的题目哈,题目大意就是给你一个十进制数N,以及目标进制b,让你把N转换成b进制数之后,判断这个b进制数是否是回文数。

坑点】这题千万不要用字符串做(我看到回文串就用字符串做…因为直接用等号判断比起数组循环来得更方便一些…但是这题不行),因为题目并没有规定10以上的数字怎么表示(通常A表示10,B表示11等等,但是这题没说,意思就是,10依然是10,11依然是11,比如16进制的FF,应该在这题里是15 15),因此,只能用数组来存储一个多位数(否则的话,还是以FF为例,字符串只会输出1 5 1 5,那这显然是不正确的)——测试点2、4的坑点。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100010;
int a[maxn] = {0};
int TentoD(int x, int D){
    int len = 0;
    if(x==0){
        len++;
    }
    else{
        while(x!=0){
            int v = x%D;
            x /= D;
            a[len++] = v;
        }
    }
    reverse(a, a+len);
    return len;
}
int main()
{
    int N, b;
    scanf("%d%d", &N, &b);
    bool flag = true;
    int Len = TentoD(N, b);
    if(N==0) flag = true;
    else{
        for(int i=0, j=Len-1;i<Len, j>=0;i++, j--){
            if(a[i]!=a[j]) flag = false;
        }
    }
    if(flag==true){
        cout<<"Yes\n";
        for(int i=0;i<Len;i++){
            if(i==0) printf("%d", a[i]);
            else printf(" %d", a[i]);
        }
    }
    else{
        cout<<"No\n";
        for(int i=0;i<Len;i++){
            if(i==0) printf("%d", a[i]);
            else printf(" %d", a[i]);
        }
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值