PAT甲级刷题记录——1085 Perfect Sequence (25分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105​​ ) is the number of integers in the sequence, and p (≤10​9​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​ .

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

思路

这题其实就是一个数学问题,题目要求输出是让你找到最多的数以形成一个“完美数列”。因此,这个题目就是让你:

确定一个左端点a[i]和一个右端点a[j],使得a[j]≤a[i]*p成立,且j-i最大。

因此,为了找到这么一条连续的若干个数的序列(《上机训练实战指南》里给出了证明方法,能使选出的数个数最大的方案,一定是在该递增序列中选择连续的若干个数的方案),可以直接用upper_bound(first, end, val)函数,来找到第一个大于val的位置(lower_bound()是找到第一个大于等于val的位置,两个在用的时候要记得减去首地址,然后得到的才是下标),因此,所得子序列的长度就是:upper_bound()-data-i(data是存放数据的数组名,也就是首地址),最后每次再比较一下子序列的长度是不是更长,然后更新一下就好啦~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100010;
int data[maxn] = {0};
int maxCnt = -1;
int main()
{
    int N, p;
    scanf("%d%d", &N, &p);
    for(int i=0;i<N;i++){
        scanf("%d", &data[i]);
    }
    sort(data, data+N);
    for(int i=0;i<N;i++){
        int pos = upper_bound(data+i+1, data+N, (long long)data[i]*p) - data;//返回第一个大于data[i]*p的位置
        int cnt = pos-i;
        if(cnt>maxCnt) maxCnt = cnt;
    }
    printf("%d", maxCnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值