1085 Perfect Sequence (25分)【二分法】

1085 Perfect Sequence (25分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

题目大意:

从n个正整数中选择若干个数,使得选择出的这些数中最大的值不超过最小值的p倍。问满足条件的选择方案中,选出的数最大个数。

解题思路:

 由于题干中涉及到序列的最大和最小值,因此不妨先将所有的n个正整数从小到大进行排序。在此基础上证明:能使得选出的数个数最大的方案,一定是在该递增序列中选择连续的若干个数的方案。

于是问题转化为:在一个给定的递增序列中,确定一个左端点a[i]和一个右端点a[j],使得a[j]<=a[i]*p成立,且j-i最大。

如果强制进行O(n^2^)的二重循环枚举,那么根据题目的数据范围,肯定是会超时的。这里有两种方法来解决这个问题:

二分法:

#include<iostream>
#include<algorithm>
using namespace std;

int n, p, arr[100010];

//在[i+1,n-1]范围内查找第一个大于x的数的位置
int binarySearch(int i, long long x)
{
	if (arr[n - 1] <= x)
		return n;
	int l = i + 1, r = n - 1, mid;
	while (l < r)
	{
		mid = (l + r) / 2;
		if (arr[mid] <= x)
		{
			l = mid + 1;
		}
		else
		{
			r = mid;
		}
	}
	return l;
}

int main()
{
	cin >> n >> p;
	for (int i = 0; i < n; i++)
		cin >> arr[i];
	sort(arr, arr + n);
	int ans = 1;
	for (int i = 0; i < n; i++)
	{
		//在a[i+1]~a[n-1]中查找第一个超过a[i]*p的数,返回其位置给j
		int j = binarySearch(i, (long long)arr[i] * p);
		ans = max(ans, j - i);
	}
	cout << ans << endl;
	return 0;
}

当然,其中的二分查找可以用upper_bound()函数来代替,可以简化很多代码。

#include<iostream>
#include<algorithm>
using namespace std;

int n, p, arr[100010];

int main()
{
	cin >> n >> p;
	for (int i = 0; i < n; i++)
		cin >> arr[i];
	sort(arr, arr + n);
	int ans = 1;
	for (int i = 0; i < n; i++)
	{
		//在a[i+1]~a[n-1]中查找第一个超过a[i]*p的数,返回其位置给j
		int j = upper_bound(arr + i + 1, arr + n, (long long)arr[i] * p) - arr;
		ans = max(ans, j - i);
	}
	cout << ans << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值