PAT甲级刷题记录——1037 Magic Coupon (25分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​C​​ ,N​P​​ ≤10​5​​ , and it is guaranteed that all the numbers will not exceed 2​30​​ .

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

思路

这题也很简单哈,题意就是让你计算两个序列每个因子一一对应相乘的最大值,显然,我们应该让正和正的两个数尽量找大的相乘,负和负的两个数尽量找小的相乘。我一开始想复杂了,想着挑一个优惠券,再去找满足要求的物品,结果导致测试点4超时了(因为两个for循环)……

其实这题非常简单,给两个序列都从大到小排好序之后,从头到尾遍历优惠券是正数的序列(for循环里可以这么写:i=0;C[i]>0;i++),这里设一个物品序列的pointer,记为k,指向第二个序列的第一位(k=0),如果此时找到P[k]>0,说明此时就是我们要的两个数,直接相乘即可(因为两个序列已经从大到小排好序了),并且k++,指向P序列的下一位。

同理,再尾到头遍历优惠券是负数的序列(因为负数的话,我们要“越负越好”的数),再设一个物品序列的pointer,记为j,指向第二个序列的最后一位(j=Np-1),如果此时恰好P[j]<0,那么两个都是负数,直接相乘即可,并且j–,指向P序列的前一位。

这么一看是不是有点像贪心+two pointers的结合hhh,总之这些pointers都是为了优化算法而做出的改变~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100010;
int C[maxn] = {0};
int P[maxn] = {0};
bool cmp(int a, int b){
    return a>b;
}
int main()
{
    int Nc, Np;
    scanf("%d", &Nc);
    for(int i=0;i<Nc;i++){
        scanf("%d", &C[i]);
    }
    scanf("%d", &Np);
    for(int i=0;i<Np;i++){
        scanf("%d", &P[i]);
    }
    sort(C, C+Nc, cmp);
    sort(P, P+Np, cmp);
    int sum = 0;
    int k = 0;
    for(int i=0;C[i]>0;i++){
        if(P[k]>0){
            sum += C[i]*P[k];
            k++;
        }
    }
    int j = Np-1;
    for(int i=Nc-1;C[i]<0;i--){
        if(P[j]<0){
            sum += C[i]*P[j];
            j--;
        }
    }
    printf("%d", sum);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值