pat 1037. Magic Coupon (25)

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
解:思路题,我起初想开四个数组的,前两个数组分别存coupon里的正值和负值,后两个存product里的正值和负值,但写的时候觉得可以简化下,只开了两个数组,其他的自己写的时候控制下,完全可以实现四个数组一样的功能。这道题,我先存值,输入的过程中统计正负值的个数,得到coupon和product对应数组中正数个数的最小值和负数个数的最小值,排序,再正正相乘+负负相乘,最后得到结果。

代码:

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int n=0,m=0;    //两数组对应的个数
    int len1=0,len2=0;  //统计两个数组中负值和正值个数的最小值

    scanf("%d",&n);
    int *a=new int[n+1];
    int cnt1=0,cnt2=0;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        if(a[i]>0) cnt1++;
        if(a[i]<0) cnt2++;
    }

    scanf("%d",&m);
    int *b=new int[m+1];
    int dnt1=0,dnt2=0;
    for(int i=0;i<m;i++)
    {
        scanf("%d",&b[i]);
        if(b[i]>0) dnt1++;
        if(b[i]<0) dnt2++;
    }

    len1=min(cnt1,dnt1);
    len2=min(cnt2,dnt2);

    sort(a,a+n);
    sort(b,b+m);

    int result=0;
    for(int i=0;i<len2;i++)
    {
        if(a[i]<0&&b[i]<0)
        {
            result+=a[i]*b[i];
        }
    }

    int j=0,en1=n-1,en2=m-1;
    while(j<len1)
    {
        j++;
        if(a[en1]>0&&b[en2]>0)
           result+=a[en1--]*b[en2--];
    }
    printf("%d\n",result);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值