PAT甲级刷题记录——1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

思路

这题非常简单……

题目要求输出所有序列中拼接出来的最小的数,因此,直接对输入的字符串排个序,然后按序拼出来输出即可(不要用C的char数组,用C++的string类型非常方便,所有运算符都给你重载好了)。

不过这里要注意的是,排序不能是简单地排升序,而是要拼起来之后再对两个字符串进行比较大小(S1+S2<S2+S1),不然就会出现32+321的情况,而事实上,应该是321+32。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 10010;
string data[maxn];
bool cmp(string a, string b){
    return a+b<b+a;
}
int main()
{
    int N;
    cin>>N;
    for(int i=0;i<N;i++){
        cin>>data[i];
    }
    sort(data, data+N, cmp);
    string result;
    for(int i=0;i<N;i++){
        result += data[i];
    }
    while(result[0]=='0'){
        result.erase(result.begin());
    }
    if(result.length()==0) cout<<"0";
    else cout<<result;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值