【PAT(甲级)】1038 Recover the Smallest Number

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

解题思路:

题目给出几个数字,让你组合出最小的类型,并且把前置零给去除。如果从数字方面考虑的话就会比较麻烦,所以我们直接换成字符串类型来比较。

字符串的小于是当前位小的就排在前面,如果相同则比较后一位。

所以只要如下代码就可以解决比较的问题:

bool cmp(string a,string b){
	return a+b<b+a;
}

易错点:

1. 去除前置0的时候,别忘记考虑全是0的情况

代码:

#include<bits/stdc++.h>
using namespace std;

int N;

bool cmp(string a,string b){//比较组合较小的字符串放在前面
	return a+b<b+a;
}



int main(){
	cin>>N;
	string number[N];
	for(int i=0;i<N;i++){
		cin>>number[i];
	}
	sort(number,number+N,cmp);
	string result;
	for(int i=0;i<N;i++){
		result+=number[i];
	}
	
	int j = -1;
	for(int i=0;i<result.size();i++){
		if(result[i]!='0'){//找到最先开始的数字
			j = i;
			break;
		}
	}
	
	if(j==-1) cout<<0;//单独列举全是0的情况
	else{
		for(int i=j;i<result.size();i++){
			cout<<result[i];
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值