PAT甲级刷题记录——1041 Be Unique (20分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print Noneinstead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

思路

这题很简单哈,题目大意就是让你输出第一个个数为0的数字,因此,需要记录读入的顺序。

用map来存储好以后,按输入顺序开始对数字进行遍历,如果碰到某个数的个数只有1个,那么直接输出,并且置flag为true,说明存在解,然后break掉。

如果遍历结束flag依然为false,则说明此时无解,输出“None”即可~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100010;
int data[maxn] = {0};
map<int, int> m;
int main()
{
    int N;
    scanf("%d", &N);
    for(int i=0;i<N;i++){
        scanf("%d", &data[i]);
        m[data[i]]++;
    }
    bool flag = false;
    for(int i=0;i<N;i++){
        if(m[data[i]]==1){
            printf("%d", data[i]);
            flag = true;
            break;
        }
    }
    if(flag==false) printf("None");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值