PAT-A1041 Be Unique 题目内容及题解

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题目大意

题目给定一组序列,选择一个数字下注,第一个投注唯一数字的人获胜。题目要求输出该数字并返回0值。

解题思路

  1. 读取序列并储存,并用Hash法对每个数字提出的数量进行计数;
  2. 按照序列顺序验证,找到计数为1的点时输出该数并退出,找不到则输出none;
  3. 返回零值。

代码

#include<stdio.h>
#define maxn 100010
int hash[10010];
int bet[maxn];

int main(){
    int N;
    int i,a;
    scanf("%d",&N);
    for(i=0;i<N;i++){
        scanf("%d",&a);
        bet[i]=a;
        hash[a]++;
    }
    for(i=0;i<N;i++){
        if(hash[bet[i]]==1){
            break;
        }
    }
    if(i<N){
        printf("%d\n",bet[i]);
    }else{
        printf("None\n");
    }
    return 0;
}

运行结果

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值