PAT甲级刷题记录——1050 String Subtraction (20分)

Given two strings S​1​​ and S​2​​ , S=S​1​​ −S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​ . Your task is simply to calculate S​1​​ −S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​ , respectively. The string lengths of both strings are no more than 10​4​​ . It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​ −S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

思路

这题很简单哈,而且我之前在Codeup上也已经做过了,不要被题目的【However, it might not be that simple to do it fast.】这句话所吓到哈。

题目大意就是给出两行字符串,让你输出第一行字符串删掉第二行字符串中所有字母之后的字符串(也就是所谓的S1-S2),那么很简单,直接用map对第二行字符串中所有字母置true,代表这是要滤去的。然后从头开始遍历第一行字符串,如果当前字母是false那么正常输出,如果是true就直接跳到下轮循环。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
map<char, bool> m;
int main()
{
    string tmp1, tmp2;
    getline(cin, tmp1);
    getline(cin, tmp2);
    for(int i=0;i<tmp2.length();i++){
        m[tmp2[i]] = true;
    }
    for(int i=0;i<tmp1.length();i++){
        if(m[tmp1[i]]==false) cout<<tmp1[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值