PAT甲级刷题记录——1083 List Grades (25分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i]and ID[i]are strings of no more than 10 characters with no space, grade[i]is an integer in [0, 100], grade1and grade2are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONEinstead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

思路

这题很简单哈,也没有什么小坑,直接按照题目要求读入数据,然后对这对数据进行成绩从大到小的排序(因为成绩保证是不同的(distinct),因此,也不存在什么第二标尺的说法了),再根据所给的区间输出这个区间里的学生就好啦~

为了判断在给定区间里是否存在至少一个学生,只要再多设一个bool型变量flag即可~如果flag在查询结束之后依然是false,就说明这个区间里一个人都没有,就输出“NONE”~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
struct student{
    string name, ID;
    int grade;
};
vector<student> List;
bool cmp(student a, student b){
    return a.grade>b.grade;
}
int main()
{
    int N;
    cin>>N;
    for(int i=0;i<N;i++){
        string tmpName, tmpID;
        int tmpGrade;
        student tmp;
        cin>>tmpName>>tmpID>>tmpGrade;
        tmp.name = tmpName;
        tmp.ID = tmpID;
        tmp.grade = tmpGrade;
        List.push_back(tmp);
    }
    sort(List.begin(), List.end(), cmp);
    int grade1, grade2;
    cin>>grade1>>grade2;
    bool flag = false;
    for(int i=0;i<List.size();i++){
        if(List[i].grade>=grade1&&List[i].grade<=grade2){
            flag = true;
            cout<<List[i].name<<" "<<List[i].ID<<'\n';
        }
    }
    if(flag==false) cout<<"NONE";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值