PAT甲级刷题记录——1154 Vertex Coloring (25分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloringif it is a proper k-coloring for some positive k, or Noif not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

思路

这题很简单哈,但是千万不要想成图论的题目(这样只会越想越复杂),其实题目本身的意思很简单,就是让你检查每条边的两个顶点的颜色是否相同,如果相同,输出“No”,否则就输出颜色的个数(这个用set存就行了,然后set的size()就是颜色的个数。但是要注意的是,所有颜色都要存进去,我一开始用map把只存在于图上点对应的颜色存进去,然后一直有一个测试点WA,把map删了就AC了……以例子来说,顶点3是不存在于图上的,但是它的颜色还是要存进去的)。

因此,直接定义一个结构体edge,里面包含左右两个端点。然后输入M条边的时候直接放入结构体数组即可。然后每输入完一次所有颜色,就遍历所有边(M条边),寻找当前边的左右两个顶点的颜色是否相同,如果相同,就退出循环,输出“No”,否则的话就输出size()。因为这里是多次查询,因此在结束之后要记得把set清空,以便放入下一次的颜色~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<set>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 10010;
struct edge{
    int v1, v2;//边的两个顶点
}Edge[maxn];
int Node[maxn] = {0};
set<int> color;
int main()
{
    int N, M;
    scanf("%d%d", &N, &M);
    for(int i=0;i<M;i++){
        int a, b;
        scanf("%d%d", &a, &b);
        Edge[i].v1 = a;
        Edge[i].v2 = b;
    }
    int K;
    scanf("%d", &K);
    for(int i=0;i<K;i++){
        for(int j=0;j<N;j++){
            int tmpColor;
            scanf("%d", &tmpColor);
            Node[j] = tmpColor;
            color.insert(tmpColor);
        }
        bool flag = true;
        for(int j=0;j<M;j++){
            if(Node[Edge[j].v1]==Node[Edge[j].v2]){
                flag = false;
                break;
            }
        }
        if(flag==false) printf("No\n");
        else printf("%d-coloring\n", color.size());
        color.clear();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值