PAT甲级刷题记录——1147 Heaps (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heapif it is a max heap, or Min Heapfor a min heap, or Not Heapif it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

思路

这题和【1155 Heap Paths (30分)】如出一辙哈,甚至比1155还简单一些,那题还需要DFS遍历,这题是判断完堆的性质之后输出这个堆的后序序列,因为堆是一棵完全二叉树,所以这里直接用数组存储就好了~

因为题目要给出多个堆,所以这里要定义一个二维数组[M][N+1](之所以第二维要+1是因为完全二叉树的结点是从1开始算的,否则写后续遍历的时候会很麻烦)。然后对每个输入的完全二叉树进行判断是否是堆(这里可以直接用<algorithm>头文件里的is_heap()函数进行判断,默认判断是否是大顶堆,如果加上greater<int>()这个参数的话,就会判断是否是小顶堆),判断完之后再对当前树进行一次后续遍历即可~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100;
int v[100][1001];
void postOrder(int root, int N, int index, int &cnt){
    if(root>N) return;
    postOrder(2*root, N, index, cnt);
    postOrder(2*root+1, N, index, cnt);
    if(cnt==0){
        printf("%d", v[index][root]);
        cnt++;
    }
    else printf(" %d", v[index][root]);
}
int main()
{
    int M, N;
    scanf("%d%d", &M, &N);
    for(int i=0;i<M;i++){
        for(int j=1;j<=N;j++){
            scanf("%d", &v[i][j]);
        }
    }
    for(int i=0;i<M;i++){
        if(is_heap(v[i]+1, v[i]+N+1)==true){
            printf("Max Heap\n");
        }
        else if(is_heap(v[i]+1, v[i]+N+1, greater<int>())==true){
            printf("Min Heap\n");
        }
        else printf("Not Heap\n");
        int cnt = 0;
        postOrder(1, N, i, cnt);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值