PAT甲级刷题记录——1140 Look-and-say Sequence (20分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where Dis in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one Din the 1st number, and hence it is D1; the 2nd number consists of one D(corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D= 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D(in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

思路

这题也很简单哈,最重要的步骤我认为在于看懂题目……其实就是每一个新的序列是对上一个序列的描述。比如题目给的D样例,第一个是一个D,因此,第二个应该输出D1(代表着D有1个意思),于是,第三个应该输出D111(代表着D有1个、1有1个的意思),第四个应该输出D113(代表着D有1个,1有3个的意思),以此类推……

然后就很简单了,直接照着这个意思对输入的数进行模拟即可~

这里说一下容易忘掉或者漏掉的地方:

  • 不要忘了把最后一位的数给加上(我这里是选择在循环结束之后加上最后一位的数和它对应的个数);
  • 其次,还应该注意当输入的N是1时要特判输出D本身(否则测试点3会WA)。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
int cnt[10] = {0};
int main()
{
    int D, N;
    cin>>D>>N;
    if(N==1) cout<<D;
    else{
        int nowN = 1;
        string ori = to_string(D);
        string pre = ori;
        string next;
        while(nowN<N){
            next.clear();//一定要记得在每次循环前清空next,否则会串在上一次的结果里
            int nowCnt = pre[0]-'0';
            cnt[nowCnt]++;
            for(int i=1;i<pre.length();i++){
                if(pre[i]-'0'==nowCnt){
                    cnt[nowCnt]++;
                }
                else{
                    next += nowCnt+'0';
                    next += cnt[nowCnt]+'0';
                    cnt[nowCnt] = 0;
                    nowCnt = pre[i]-'0';
                    cnt[nowCnt]++;
                }
            }
            next += nowCnt+'0';
            next += cnt[nowCnt]+'0';
            cnt[nowCnt] = 0;
            pre = next;
            nowN++;
        }
        cout<<next;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值