PAT Advanced 1110 Complete Binary Tree

1110 Complete Binary Tree

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -    

Sample Output 1:

YES 8  

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- - 

Sample Output 2:

NO 1

解题思路

给定若干的二叉树,问是够能够组成一颗完全二叉树, 是的话输出完全二叉树中最后一个元素, 如果不是输出根节点。 符合是完全二叉树的条件是从根节点遍历,到最后元素的下标值等于节点个数值

输入方式: 行数代表根节点,行数输出的值为根节点元素,如果如果为空,用-带替。

过程

  1. 找到根节点,二叉树的性质中根节点不会作为子节点, 图示中的根节点就是6,通过hash的方法找到根节点。
  2. 遍历选择dfs,这样方便找对应节点的下标。
  3. 判断是否是完全二叉树, 如果是完全二叉树的话节点个数和最后一个节点的下标数相同,如果不是的话,那么最后一个节点的下标数 > 节点数, 因为其中存在不连续的下标值,所以最后一个节点的下标数一定比节点个数的值大。

图示

给定的起始的二叉树如下:

完成构建二叉树:

解题代码

#include <iostream>
using namespace std;
int btree[25][2], a[25];
int n, idx, last;
void dfs(int v, int  cur){
    if (v == -1) return;
    if (idx < cur) idx = cur, last = v;
    dfs(btree[v][0], 2 * cur);
    dfs(btree[v][1], 2 * cur + 1);
}
int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        string sl, sr;
        cin >> sl >> sr;
        btree[i][0] = btree[i][1] = -1;
        if (sl != "-") btree[i][0] = stoi(sl), a[stoi(sl)] = 1;
        if (sr != "-") btree[i][1] = stoi(sr), a[stoi(sr)] = 1;
    }
    int root;
    for (int i = 0; i < n; i++) if (!a[i]) root = i;
    dfs(root, 1);
    if (idx == n) printf("YES %d", last);
    else printf("NO %d", root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是用C语言实现判断二叉树是否为完全二叉树的代码: ```c #include <stdio.h> #include <stdlib.h> // 定义二叉树结点 struct Node { int val; struct Node *left, *right; }; // 计算二叉树的结点数量 int countNodes(struct Node* root) { if (root == NULL) { return 0; } return 1 + countNodes(root->left) + countNodes(root->right); } // 判断二叉树是否为完全二叉树 int isCompleteTree(struct Node* root, int index, int numNodes) { // 如果为空树,返回true if (root == NULL) { return 1; } // 如果当前结点的索引超过了结点数量,返回false if (index >= numNodes) { return 0; } // 递归判断左右子树是否为完全二叉树 return isCompleteTree(root->left, 2 * index + 1, numNodes) && isCompleteTree(root->right, 2 * index + 2, numNodes); } int main() { // 创建一个二叉树 struct Node* root = (struct Node*)malloc(sizeof(struct Node)); root->val = 1; root->left = (struct Node*)malloc(sizeof(struct Node)); root->left->val = 2; root->left->left = (struct Node*)malloc(sizeof(struct Node)); root->left->left->val = 4; root->left->right = (struct Node*)malloc(sizeof(struct Node)); root->left->right->val = 5; root->right = (struct Node*)malloc(sizeof(struct Node)); root->right->val = 3; root->right->left = (struct Node*)malloc(sizeof(struct Node)); root->right->left->val = 6; int nodeCount = countNodes(root); int index = 0; if (isCompleteTree(root, index, nodeCount)) { printf("This is a complete binary tree.\n"); } else { printf("This is not a complete binary tree.\n"); } return 0; } ``` 该程序首先定义了一个二叉树结点的结构体,包含结点值、左右子树的指针。接着定义了两个函数: - `countNodes`:计算二叉树的结点数量,使用递归方式遍历二叉树,每遍历一个结点,就累加1,最终返回结点数量。 - `isCompleteTree`:判断二叉树是否为完全二叉树,使用递归方式遍历二叉树,同时记录每个结点的索引。如果当前结点的索引超过了结点数量,说明已经遍历到了不存在的结点,因此返回false。如果当前结点的索引小于结点数量,就继续递归遍历它的左右子树,直到遍历完整棵树。如果递归过程中没有返回false,说明该树是完全二叉树,返回true。 在主函数中,我们创建了一个二叉树,并调用`countNodes`计算结点数量,调用`isCompleteTree`判断二叉树是否为完全二叉树。最终根据返回值输出判断结果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值