【PAT甲级 - C++题解】1043 Is It a Binary Search Tree

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1043 Is It a Binary Search Tree (pintia.cn)
🔑中文翻译:判断二叉搜索树
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO
题意

二叉搜索树 (BST) 递归定义为具有以下属性的二叉树:

  • 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值
  • 若它的右子树不空,则右子树上所有结点的值均大于或等于它的根结点的值
  • 它的左、右子树也分别为二叉搜索树

我们将二叉搜索树镜面翻转得到的树称为二叉搜索树的镜像。

现在,给定一个整数序列,请你判断它是否可能是某个二叉搜索树或其镜像进行前序遍历的结果。

如果是某个二叉搜索树或其镜像进行前序遍历的结果,则输出 YES ,并输出其后序遍历的结果,否则输出 NO

思路
  1. 先输入先序遍历的数组,然后可以通过该数组进行排序,就得到了中序遍历的数组,因为二叉搜索树的中序遍历数组是有序的。

  2. 然后分别去判断该树是否为二叉搜索树或者镜像二叉搜索树,判断方法和之前的一道题根据后序数组以及中序数组来构建二叉树思想很类似,这里是根据前序数组以及中序数组来判断是否为二叉搜索树或镜像二叉搜索树。我们只用搞定二叉搜索树的判断,镜像二叉搜索树的判断就出来了,只用将前面的操作进行一个逆向翻转即可。下面我给出正常二叉搜索树的判断图(其中 k-il-1 表示左子树结点个数):

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-fKO0crkb-1664102693672)(PAT 甲级辅导.assets/4.png)]

  3. 如果满足要求,输出该树的后序遍历即可。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 1010;
int inorder[N], preorder[N], postorder[N];
int n, cnt;

bool build(int il, int ir, int pl, int pr, int type)
{
    if (il > ir)   return true;

    int root = preorder[pl];
    int k;
    if (!type)   //对二查搜索树的判断
    {
        for (k = il; k <= ir; k++) //找到该结点在中序序列中的位置
            if (root == inorder[k])
                break;
        if (k > ir)    return false;
    }
    else    //对镜像二叉搜索树的判断
    {
        for (k = ir; k >= il; k--)
            if (root == inorder[k])
                break;
        if (k < il)    return false;
    }

    //递归判断其左右子树是否满足要求
    int res = true;
    if (!build(il, k - 1, pl + 1, pl + 1 + (k - il - 1), type))  res = false;
    if (!build(k + 1, ir, pl + 1 + (k - il - 1) + 1, pr, type))  res = false;

    postorder[cnt++] = root;  //将根结点加入后序数组中

    return res;
}

int main()
{
    //输入结点信息
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> preorder[i];
        inorder[i] = preorder[i];
    }

    sort(inorder, inorder + n);    //获得中序序列

    if (build(0, n - 1, 0, n - 1, 0))    //判断是否为二叉搜索树
    {
        puts("YES");
        cout << postorder[0];
        for (int i = 1; i < cnt; i++)  cout << " " << postorder[i];
        cout << endl;
    }
    else    //判断是否为镜像二叉搜索树
    {
        reverse(inorder, inorder + n);
        cnt = 0;
        if (build(0, n - 1, 0, n - 1, 1))
        {
            puts("YES");
            cout << postorder[0];
            for (int i = 1; i < cnt; i++)  cout << " " << postorder[i];
            cout << endl;
        }
        else    puts("NO");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值