pat甲级 树A1099 Build A Binary Search Tree (30分) 构建二叉搜索树

1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

 题目大意:给出0到n-1个节点的左右孩子下标,和n个结点的权值,构造一棵二叉搜索树,然后层序输出。

ps:二叉搜索树的中序遍历为递增序列。

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;
struct Node
{
    int data;
    int left,right;
}node[110];
//vector<Node> index(110);
//vector<int> v;
int v[110];
int k=0;
int n;
void inOrder(int root)//利用中序遍历建树
{
    if(root==-1) return;
    inOrder(node[root].left);
    //vi.push_back(v[k++]);
    node[root].data=v[k++];
    inOrder(node[root].right);
}
void bfs(int root)//层序遍历
{
    queue<int> q;
    q.push(root);
   // int top=q.front();
    int num=0;
    while(!q.empty())
    {
        int top=q.front();
        q.pop();
        //cout<<node[top].data;
        printf("%d",node[top].data);
        num++;
        if(num<n) //cout<<" ";
            printf(" ");
        if(node[top].left!=-1) q.push(node[top].left);
        if(node[top].right!=-1) q.push(node[top].right);
    }
}
int main()
{
   // int n;
    int left,right;
   // cin>>n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
       // cin>>left>>right;
        scanf("%d %d",&left,&right);
        node[i].left=left;
        node[i].right=right;
    }
    for(int i=0;i<n;i++)
    {
        //cin>>v[i];
        scanf("%d",&v[i]);
    }
    sort(v,v+n);//二叉搜索树的中序遍历为递增序列
   // sort(v,v+n);
    inOrder(0);
    bfs(0);
    //cout<<level[0];
    //for(int i=1;i<level.size();i++)
     //   cout<<" "<<level[i];
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值