1122 Hamiltonian Cycle (25分)
The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2
, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 ... Vn
where n is the number of vertices in the list, and Vi's are the vertices on a path.
Output Specification:
For each query, print in a line YES
if the path does form a Hamiltonian cycle, or NO
if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
参考柳神: https://www.liuchuo.net/archives/2748
#include<iostream>
#include<vector>
#include<set>
using namespace std;
int main(){
int n,m,k,q,a,b,edge[1000][1000]={0};
cin>>n>>m;
for(int i=0;i<m;i++){
cin>>a>>b;
edge[a][b]=edge[b][a]=1;
}
cin>>k;
for(int i=0;i<k;i++){
bool flag1=true,flag2=true;
scanf("%d",&q);
vector<int> v(q);
set<int> se;
for(int i=0;i<q;i++){
scanf("%d",&v[i]);
se.insert(v[i]);
}
int len=v.size();
if(se.size()!=n||(len!=n+1)||v[0]!=v[len-1])
flag1=false;
for(int i=0;i<len-1;i++){
if(edge[v[i]][v[i+1]]==0)//所给结点边不存在
{
flag2=false;
break;
}
}
if(flag1==true&&flag2==true)
printf("YES\n");
else printf("NO\n");
}
return 0;
}