pat 甲级 并查集 A1118 Birds in Forest (25分)

1118 Birds in Forest (25分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

 题意:分别给出n幅画里鸟的个数k,然后给出这幅画里k只鸟的编号。出现在同一幅画里的鸟在同一棵树上,求总共有几棵树和鸟的数量。

然后给出Q个查询,查询两只鸟是否在同一棵树上。

#include<iostream>
using namespace std;
const int maxn=10010;//最多鸟的编号
int father[maxn];
bool exist[maxn]={false};
void init(){
	for(int i=1;i<=maxn;i++)
	father[i]=i;
}
int findFather(int x){
	if(father[x]==x) return x;
	else{
		int f=findFather(father[x]);
		father[x]=f;
		return f;
	}
}
void Union(int a,int b){
	int fa=findFather(a);
	int fb=findFather(b);
	if(fa!=fb) father[fa]=fb;
}
int main(){
	init();
	int n,k,q,id,temp;
	//cin>>n;
    scanf("%d",&n);
	for(int i=0;i<n;i++){
		//cin>>k>>id;
        scanf("%d %d",&k,&id);//输入此幅画鸟的个数k和第一只鸟的编号
		exist[id]=true;
		for(int j=0;j<k-1;j++){
			scanf("%d",&temp);
			exist[temp]=true;
			Union(id,temp);
		}
	}
	int cnt=0,sum=0,isRoot[maxn]={0};
	for(int i=1;i<=maxn;i++){
		if(exist[i])
		isRoot[findFather(i)]++;
	}
	for(int i=1;i<=maxn;i++){
	   if(isRoot[i]!=0&&exist[i]==true){
	   	cnt++;//树的个数
	   	sum+=isRoot[i];//鸟的个数
	   }
	}
	//cout<<cnt<<" "<<sum<<endl;
    printf("%d %d\n",cnt,sum);
	//cin>>q;
    scanf("%d",&q);
	int a,b;
	for(int i=0;i<q;i++){
		scanf("%d %d",&a,&b);
        printf("%s\n",findFather(a)==findFather(b)?"Yes":"No");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值